The technical issue that affected US Payouts on May 27th has been fully resolved.
Funds Delivered: All delayed payouts from Wednesday, May 27th, were successfully delivered yesterday, Thursday, May 28th.
Combined Deposits: As previously noted, merchants received their delayed funds alongside their regularly scheduled May 28th payouts, resulting in a double deposit day.
Current Status: Systems are operating normally. Payouts for today, Friday, May 29th, and all future dates are processing on their standard schedules.
Posted May 29, 2026 - 04:04 EDT
Monitoring
Lightspeed Payment Retail US only:
Due to a technical issue experienced by one of our processing partners, payouts originally set to arrive yesterday were delayed by one business day. We can confirm that this issue has been fully resolved.
What this means for you:
Double Payout Today: Affected merchants will receive two separate deposits in their bank accounts today, May 28th.
The first deposit covers the delayed funds from May 27th.
The second deposit is your regularly scheduled payout for May 28th.
Posted May 28, 2026 - 04:37 EDT
This incident affected: Lightspeed Restaurant (K-Series) (Lightspeed Payments).