Issues processing transactions via Lightspeed Payments

Incident Report for Lightspeed - Status Page

Resolved

The issue preventing merchants from completing transactions using Lightspeed Payments has been fully resolved.
Posted Jun 18, 2026 - 12:13 EDT

Monitoring

We are currently investigating an issue where merchants are unable to complete transactions using Lightspeed Payments.
Posted Jun 18, 2026 - 11:58 EDT
This incident affected: Lightspeed Retail (X-Series) (Payments).